optile - LIVE Security Update
Scheduled for May 28, 17:00 - 18:00 CEST
Update
Please be advised that the date for the Security Update we announced yesterday will be move from the 13th May to the 28th May at 17:00 CEST.

Kind regards
Posted May 08, 2024 - 11:50 CEST
Scheduled
We will be carrying out a security update to our live environment. We do not expect any downtime whilst the update takes place.

The live update will take place on the 13th May 2024 at 17:00 CEST.

If you have any questions please reach out to support.

Kind regards
Payoneer Support
Posted May 07, 2024 - 11:10 CEST
This scheduled maintenance affects: PST 1 - Critical Payment Operations, PST 2 - Non-Critical Payment Operations, and PST 3 - Non-Payment Operations.